Tutoriais‎ > ‎

Ferramentas

Para organizar os tutoriais, resolvi dividir a pagina de tutoriais em categorias.

Nesta seção iremos descrever as ferramentas em geral.

Resumo CLI Cisco

postado em 15 de jul. de 2014 03:52 por Prof. Rodrigo Costa   [ 9 de set. de 2016 12:40 atualizado‎(s)‎ ]

Nos roteadores existem quatro níveis de execução:
  • Modo executivo do usuário (EXEC usuário): Modo no qual o usuário pode ver configurações básicas
  • Modo executivo privilegiado (EXEC privilegiado): Permite executar qualquer comando do sistema. Possui o sub-modo:
    • Modo de configuração global: configurações gerais do equipamento para o monitoramento do dispositivo
    • Outros modos de configuração específicos, como o modo de configuração da interface: configurações especializadas para funcionalidades especiais do equipamento
Para conhecer todos os comandos disponíveis em uma versão da cisco deve-se procurar o site http://www.cisco.com/c/en/us/support/ios-nx-os-software/ios-15-2m-t/products-command-reference-list.html
na dúvida. use o comando show para ver os comandos ou escolha uma letra e aperte o botão de interrogação.

exemplo: cl? -> clock or clear
clock ?: mostra os parametros do comando clock

Comandos EXEC usuário: Hostname>  

Este modo é caracterizado pelo nome do equipamento seguido do metacaractere >. EX: Roteador>
Ele é conhecido como modo somente leitura e permite os seguintes comandos:
  • enable: alterna o modo de execução pivilegiado.
  • show ?: lista os comandos do modo EXEC usuário
    • show version: mostra as caracteristicas do sistema operacional do dispositivo.
  • ping ip: testa conectividade com o IP fornecido
  • traceroute ip: verifica a rota;
  • exit: retorna para a tela de login do equipamento

Comandos do Modo EXEC privilegiado: Hostname#

Este modo é caracterizado pelo nome do equipamento seguido do metacaractere #. EX: Roteador#
Permite o monitoramento e a alteração de configurações do equipamento
  • disable ou exit: sai do modo privilegiado e volta para o modo de execução de usuário.
  • configure terminal ou conf t: alterna para o modo de execução de configuração global 
  • show: mostra configurações
    • show running: permite verificar as configurações atuais do dispositivo.
    • show flash: mostra os sistemas que estao disponíveis no equipamento
    • show processes: mostra os programas em execução
    • show startup config: mostra as configurações padrões do dispositivo.
    • show ip interface brief: verifica as configurações de IP das inerfaces de rede.
    • show boot: .mostra as variáveis de inicialização do boot. informa qual é a imagem a ser carregada e seu local.
    • show mac-address-table .mostra a tabela mac do switch
    • show interface <nome> .mostra as informações específicas de uma única porta do switch
    • show interface tunel <numero>: mostra as informações do Tunel GRE criado e estabelecido entre os roteadores.
    • show frame-relay lmi: mostra algumas estatísticas da LMI.Ex. mostra o número de mensagens de status trocadas entre o roteador local e o switch local do Frame Relay
    • show frame-relay lmi: mostra algumas estatísticas da LMI.Ex. mostra o número de mensagens de status trocadas entre o roteador local e o switch local do Frame Relay
    • show frame-relay pvc [interface interface] [dlci]: mostra informações da interface frame-relay
    • show frame-relay inverse-arp: mostra informações do arp inverso.
    • show port-security address.mostra os endereços mac seguros.
    • show ip ssh.mostra quais as configurações do ssh configurado no switch
    • show ssh.mostra os clientes conectados.
    • show running-config interface <NomeDaInterface> mostra as configurações iniciais da interface.
    • show ipv6 interface brief. mostra as configurações de ipv6 das interface
    • show ipv6 route. mostra as rotas ipv6
    • show ip route. mostra as rotas ipv4
    • show ip protocols. mostra os algoritmos de roteamento que estão em execução no roteador.
    • show ipv6 routers
    • show history. mostra os últimos comandos presentes no histórico.
    • show ip route rip. mostra a tabela de roteamento rip.
    • debug ip route. mostra o processo de atualiação do rip;
    • undebug ip route. remove a depuração do processo de roteamento;
    • debug frame-relay lmi: torna possível determinar se o roteador e o switch do Frame Relay estão enviando e recebendo pacotes de LMI adequadamente
    • debug ppp: mostra o processo de comunicação PPP
    • debug ppp negotiation: mostra o processo de negociação PPP
    • debug ppp error: mostra os erros do PPP
    • debug ppp authentiaction: mostra informações da autenticação do PPP
    • undebug all. remove todos os processos de depuração.
    • show standby : permite a verificação do status operacional de um roteador configurado em um sistema de redundância de gateway através de um roteador virtual utilizando o protocolo HSRP.
    • show standby brief: exibe um resumo da configuração dos roteadores em um grupo virtual através do protocolo HSRP.
    • show glbp: permite a verificação do status operacional do protocolo de redundância de gateways com balanciamento de carga.
    • show etherchannel summary permite a verificação do status operacional do EterChannel.
    • show ospf neighbor verifica se o roteador formou uma adjacência com seus roteadores vizinhos.
    • show ip protocols verifica as informações de configuração vital OSPF
    • show ip ospf exibe informações do ID do processo OSPF e do ID do roteador, assim como o SPF e a área do OSPF.
    • show ip ospf interface:  fornece uma lista detalhada para cada interface
    • show ip ospf interface brief:  fornece uma lista detalhada para cada interface de forma resumida.
    • show logging: mostra informações de logging
  • clear frame-relay inarp: limpa a tabela de aro

Comandos do Modo Configuração Global: Hostname (config)#

Este modo é caracterizado pelo nome do equipamento seguido da palavra config entre parenteses e do metacaractere >. EX: Roteador (config) #
Neste modo é possível configurar o equipamento como um todo como seu nome, senha, login ou permitir o acesso ao modo de execução específico. Estão listados os principais comandos a seguir:
  • ctrl + z ou exit sai do modo de execução global e retorna para o modo privilegiado.
  • hostname NOME: altera o nome do roteador.
  • no hostname: remove o nome do host
  • enable password <senha>: habilita a senha de acesso ao modo privilegiado. Esta senha é armazenada não criptografada.
  • enable secret <senha>: habilita a senha de acesso ao modo privilegiado. Esta senha é armazenada criptografada.
  • service password-encryption: criptografa as senhas não criptografadas no arquivo de startup config.
  • show running-config: exibe as configuração atual do dispositivo
  • show startup-config: exibe as configuração padrão do dispositivo.
  • write: guarda a configuração atual como novas configurações padrão. equivale a: copy running-config startup-config
  • reload: recarrega a configuração padrão. Equivale ao copy startup-config running-config 
  • erase startup-config: apaga o arquivo de configuração padrão retornando as configurações de fábrica.
  • interface <tipo> <numero da interface>. Ex: interface gigabitEthernet 0/0.  Altera para o modo de configuração específico da interface selecionada.
  • interface range type module/first-number – last-number:  permite a configuração de múltiplas interfaces simultaneamente
  • interface Se0/0/0.<id> [multipoint | point-to-point] : define uma sub-interface para subdividir uma rede de Frame Relay parcialmente em mesh em um número de sub-redes menores.
  • interface tunel <numero>: cria uma interface de um tunel GRE.
  • clock set <HH:MM:SS.MS MES DIA ANO>: configura o horario do dispositivo manualmente.
  • ntp server <ip>: configura que o relogio do dispositivo seja sincronizado por um servidor de horário.
  • logging <destino = console , IP do Syslog Server, buffered > <tipo de logs>: configura o comportamento logging para o destino informado .
  • logging on: habilita o armazenamento dos logs
  • logging trap <severidade>: configura o log nivel de log maximo dos logs informados.... Ex: logging trap 5, limita os logs abaixo ou igual a 5.
  • logging source <interface>para definir a interface origem das mensagens syslog.
  • router <modo> <numero>. Ex: router egrp 1. Alterna para o modo de configuração específico de roteamento. Permite os modos EIGRP, OSPF e RIP.
  • line console <numero>: Ex: line console 0. Alterna para o modo de configuração de linha. Ex: line console 0  configura o terminal via porta de console e line vty 0 X configura a interface X a acesso ssh.
  • vlan ID .entra no modo de confiiguração das informações de uma vlan. É possível alterar o nome dessa rede virtual.
  • ip default gateway .define o gateay padrão de um switch. útil para fazer o switch ser configurável através de redes remotas.
  • ip domain-name <nome> .define o nome de host de rede (DNS) do switch
  • ip dhcp snoping. habilita segurança contra ataques DHCP (rastreamento ou privação de serviço)
  • ip dhcp snoping vlan <id>.ativa a segurança DHCP para uma vlan específica
  • ntp master [stratum]. :configura o switch para ser o servidor ntp.
  • ntp server ip-address: configura o switch para receber o horário de um servidor ntp
  • terminal :configura o prompt de comando
    • terminal length # : configura o numero de linhas a serem exibidas antes do terminal pausar.
    • terminal history size #: configura a quantidade de linhas presentes no histórico 
  • router rip: abre o modo de configuração de roteador com o algoritmo rip
  • no ip domain-lookup: desabilita a resolução de nomes.
  • Configurações do SSH
    • crypto key generate <tipo> .cria uma chave de criptografia a ser usada pelo SSH.
    • username <nome> secret <senha>.cria um usuario para o SSH.
    • ip ssh version 2.define a versão 2 do protocolo SSH;
    • ip ssh authentication-retries 2: limita a 2 tentativas de autenticação;
    • ip ssh time-out 60: limita o tempo de autenticação a 60 segundos. 
  • do ..... : permite a utilização de comandos do modo de configuração privilegiado dentro dos modos de configuração.
  • spanning-tree mode <modo> : especifica o modo de operação do spanning tree. Opções : pvst ou rapid-pvst
  • spanning-tree portfast bpduguard default  :  ativa o BPDU guard em todas as portas com PortFast ativado.
  • spanning-tree vlan <vlan-id> root primary :  assegura que um switch tenha o menor valor de prioridade de bridge (escolhe o raiz).
  • spanning-tree vlan <vlan-id> root secondary :  define um switch alternativo para caso a bridge raiz falhar.
  • spanning-tree vlan <vlan-id> priority <prioridade> :  define um valor de prioridade de bridge (múltiplo de 4096) para o switch
  • clear spanning-tree detected protocols:  define um valor de prioridade de bridge (múltiplo de 4096) para o switch
  • key chain <nome da chave>:  cria um conjunto de chaves
    • key <id>:  especifica o ID da chave
    • key-string <key-string-text>:  sequencia de chaves da chave

Comandos do Modo Configuração de linha (line console 0 ou line vty 0 X) : Hostname (config-line)#

Este modo permite a configuração de segurança dos canais de comunicação do dispositivo, tornando possível proteger a porta de console, bem como, habilitar portas de gerenciamento remoto através de telnet.
Geralmente o modo console só possui uma interface de número 0 por isso o comando line console 0. A maioria dos equipamentos permitem 5 linhas de consoles telnet, mas pode chegar até 16 linhas (X), numeradas de 0 a 15.
  • password <senha>: define uma senha para acesso a interface de configuração
  • login:  configura o equipamento para exigir uma senha para a linha de console.
  • no login: remove a exigência de senha para o acesso a linha de console ou telnet.
  • banner motd "mensagem": insere uma mensagem de Login.
  • transport input ssh.cria um usuario para o SSH.
  • login local:.faz a linha ter uma autenticação por usuário criado localmente no switch
  • loggin synchronous: Prevent device status messages from interrupting command line entries at the device console.

Comandos do Modo Configuração de interface (interface vlan X ou interface GigabitEthernet 0/0): Hostname (config-if)#

Este modo permite a configuração de interfaces de rede ou redes virtuais.
  • ip address <ip> <mascara>: configura o ip e a mascara de rede da interface ou da VLAN.
  • ipv6 address ipv6-address / prefix-length : configura um ipv6 unicast na interface
  • ipv6 address ipv6-address / prefix-length eui-64: configura um ipv6 unicast na interface com identificador 
  • ipv6 address ipv6-address / prefix-length link local: configura um ipv6 de link estático 
  • no shutdown : liga a interface
  • shutdown: desliga a interface.
  • description TEXTOcoloca uma descrição na interface.
  • clock rate <TAXA>define a taxa de clock em portas seriais que serão DCE (Data Communication Equipment). Sempre existe um DTE ligado num DCE.
  • bandwidth <TAXA>: altera a largura de banda informada de portas seriais..
  • ip ospf cost <TAXA>altera apenas o custo do OSPF da interface
  • Segurança de VLANs
    • switchport mode trunk: configura a porta para o modo tronco (portas nativa) IEEE 802.1Q
    • switchport trunk native vlan <id> .associa a vlan a interface de rede atual e configura-a como modo nativa. 
    • switchport trunk allowed vlan <id>,<id>,<id>-<id> .permite o tráfego das vlans listadas através do tronco.
    • switchport nonegociate.desabilita o protocolo DTP (Dynamic Trunk)
    • no switchport trunk allowed : remove todas as vlans permitidas do tronco
    • switchport mode dynamic auto: configura a porta para detectar as configurações (tronco ou não tronco).
    • switchport mode dynamic desirable: configura a porta para detectar as configurações e se colocar em modo tronco caso sua visinha também o seja.
    • switchport mode access: configura a porta para o modo de acesso.
    • no switchport trunk native vlan: desassocia a vlan nativa da interface atual
    • switchport access vlan <id> .associa uma vlan a uma interface de rede. Assim, é possível fazer com que uma interface de rede sirva como acesso ao ip de uma vlan configurada no switch.
      • Ex:
        sw1 $ en
        sw1# conf t
        sw1 (config)# interface fa0/1
        switchport access vlan 99
    • no switchport access vlan: remove a associação da porta para a vlan atual, retornando-a para a vlan padrão VLAN1.
  • Configuração da Operação de Interface
    • duplex <tipo>.permite definir a forma de comunicação da interface <tipo> pode ser half para half duplex, full para full duplex ou auto para autodetectar.
    • speed <tipo>:.define a velocidade da porta. <tipo> pode ser 10 100 ou 1000.
    • mdix auto:.define a interface para detectar automaticamente o cabo usado (MDIX).
  • Configuração de segurança de porta
    • ip dhcp snoping trust. define a interface que está sendo configurada como confiável. esta porta poderá possuir um servidor DHCP pois esta configuração permite que sejam enviados através dessa porta confirmações DHCP.
    • ip dhcp snoping limit rate <qtd>. limita a quantidade de solicitações dhcp que popdem ser feitas por cada porta.
    • switchport port-security:.habilita a segurança por porta. Requer que a porta não esteja no modo  switchport mode dynamic
    • switchport port-security mac-address <mac-address>:.cadastra um mac específico como seguro na interface selecionada.
    • switchport port-security mac-address sticky. habilita a porta para aprender os mac seguros automaticamente
    • port-security violation {protect - bloqueia o tráfego mas não dá alertas| restrict - bloqueia o tráfego, mas faz um syslog| shutdown - desabilita a porta caso aconteça uma tentativa inválida}.. configura o que acontece quando o switch tem a tabela mac da porta cheia.
  • NAT
    • nat inside: define a interface como interna para o NAT
    • nat outside: define a interface como interna para o NAT
  • Roteamento de VLAN
    • encapsulation dot1q <vlan num>: habilita uma porta para ser utilizada com o roteamento sticky. Antes é necessário criar através do comando interface <tipo>/intNum.subinterface
  • Roteamento
    • Estático: configuração genérica usa o comando a seguir ip route network-address subnet-mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ] [ name name ] [ permanent ] [ tag tag ]. A seguir alguns exemplos
      •  ip route <network> <mask> <ip-address>: configura o endereço do próximo salto. 
        Ex: ip route 0.0.0.0 0.0.0.0 192.168.0.1 : configura a rota padrão para o IP desejado
      •  ip route <network> <mask> <interface / porta >: configura o próximo salto para ser realizado pela interface  
        Ex: ip route 0.0.0.0 0.0.0.0 Se0/0/1: configura a rota padrão para ser encaminhado pela porta Serial 0/0/1
      •  ip route <network> <mask> <ip-address> <interface / porta >: configura o endereço do próximo salto e força o envio pela interface selecionada. 
      •  ip route <network> <mask> <ip-address> <metrica>configura o endereço do próximo salto e muda a distância administrativa da porta.
    • OSPF
      • clear ip ospf process: reseta o processo ospf.
      • ip ospf priority <valor>: define a prioridade da interface selecionada no OSPFv2. Caso <valor> seja 0, o roteador não vai poder se tornar BR/BDR, <valor> pode ser atribuído com valores de 1 a 255.
      • ip ospf hello-interval <tempo>: define manualmente o intervalo de hello.
      • ip ospf dead-interval <tempo>: define manualmente o intervalo de hello.
      • ip ospf message-digest-key key md5 password: configura interface enviará as mensagens OSPF utilizando uma chave de criptografia pública (assinatura)
      • ip ospf authentication message-digest: habilita a interface a enviar as mensagens autenticadas.
      • ipv6 ospf <ID> area <num>: define que a interface selecionada para participar do OSPF.
      • ip6 ospf hello-interval <tempo>: define manualmente o intervalo de hello.
      • ip6 ospf dead-interval <tempo>: define manualmente o intervalo de hello.
      • priority OSPF ipv6 <valor> define que a prioridade da interface no processo OSPFv3
    • Redundância de Gateway
      • standby <numero_do_grupo> ip <endereço_do_gateway_virtual> : configura o roteador para participar de um grupo que representa um roteador virtual utilizando o protocolo HSRP.
      • standby <numero_do_grupo> priority <numero> : define a prioridade do roteador dentro do grupo que representa um roteador virtual utilizando o protocolo HSRP.
      • glbp <numero_do_grupo> ip <endereço_do_gateway_virtual> : configura o roteador para participar de um grupo que representa um roteador virtual utilizando o protocolo GLBP.
      • glbp <numero_do_grupo> priority <numero> : define a prioridade do roteador dentro do grupo que representa um roteador virtual utilizando o protocolo GLBP.
  • Spanning Tree Protocol:
    • spanning-tree cost <valor> : define um valor de custo para a interface
    • no spanning-tree cost: retorna o valor de custo para os valores padrão (2 = 10 Gbps, 4 = 1 Gbps, 19 = 100 mbps, 100 = 10 mbps)
    • spanning-tree portfast : define a interface como interface de borda do Rapid PVST
    • spanning-tree bpduguard enable : configura o BPDU guard em uma porta de acesso de Camada 2
    • spanning-tree link-type point-to-point: define a interface como ponto a ponto (uma porta operando em modo full duplex normalmente conecta um switch a um switch )
      • spanning-tree link-type shared:  define a interface como compatilhada (operando no modo half duplex conecta um switch a um hub que conecta vários dispositivos).
  • PPP: 
    • encapsulation ppp  define o PPP como o método de encapsulamento usado por uma interface serial,
    • compress [ predictor | stac ]:  define a forma de compressão de dados usados no PPP
    • ppp quality <percentual>: define um criterio de qualidade para manter a conexão PPP
    • no ppp quality: remove o criterio de qualidade (opcional)
    • ppp multilink: define que a interface faz parte de um canal multilink (varios canais formando um só canal)
    • ppp multilink group <id> : define o grupo do canal multilink associado a interface.
    • ppp authentication pap: define como algoritmo de autenticação o PAP (Password Authentication Protocol)
    • ppp authentication chap: define como algoritmo de autenticação o CHAP (Challenge Authentication Protocol)
    • ppp authentication chap pap: usa os dois, primeiro o CHAP e depois o PAP
    • ppp authentication pap chap : usa os dois, primeiro o PAP e depois o CHAP
    • ppp pap sent-username <name> password <password> : define a senha a ser aceita pelo roteador na autenticação PAP
  • FRAME RELAY: Passos - Definir ip interface / Configurar encapsulamento /Definir tipo de LMI
    • encapsulation frame-relay [cisco | ietf] : especifica o modo da interface tunel e o protocolo de transporte a ser encapsulado. Ex: mode = GRE e protocol = IP
    • frame-relay map <protocol> <protocol-address> <dlci> [broadcast] :  define a forma de mapeamento estático, caso não seja configurado, o dispositivo irá tentar fazer o ARP Inverso
    • frame-relay lmi [cisco, ANSI, Q933] : define o tipo de LMI trocada entre os dispositivos
    • frame-relay interface <dlci>: atribui uma DLCI a sub-interface

Comandos do Modo Configuração de Múltiplas interfaces (interface range FastEthernet 0/0 - 10, FastEthernet 0/15 - 20): Hostname (config-if-range)#

Este modo de configuração realiza a configuração simultânea de múltiplas interfaces de rede. Além dos comandos tradicionais de interface, neste modo de configuração é possível realizar a agregação de links através do EtherChannel

  • EtherChannel:
    • channel-group <grupo> mode desirable: cria uma interface port-channel permitindo que o switch negocie ativamente para formar um link PAgP.
    • channel-group <grupo> mode active cria uma interface port-channel permitindo que o switch negocie ativamente para formar um link LACP.
    • channel-group <grupo> mode passive cria uma interface port-channel permitindo que o switch aguarde a negociação para formar um link LACP.
    • channel-group <grupo> mode on cria uma interface port-channel.

Comandos do Modo Configuração de interface de loopback (interface loopback numero) : Hostname (config-if)#

Este modo permite a configuração de uma interface lógica para estabelecer tuneis GRE entre roteadores Cisco.
  • ip address <ip> <mascara>: configura o ip e a mascara de rede da interface  local do tunel
  • no shutdown : liga a interface
  • shutdown: desliga a interface.

Comandos do Modo Configuração de interface de Tunel GRE : Hostname (config-if)#

Este modo permite a configuração de uma interface lógica útil para testar e gerenciar um roteador cisco, tornando possível emular redes e testar processos.
  • ip address <ip> <mascara>: configura o ip e a mascara de rede da interface de loopback
  • tunel mode <mode> <protocol>: especifica o modo da interface tunel e o protocolo de transporte a ser encapsulado. Ex: mode = GRE e protocol = IP
  • tunel source <IP>:  especifica o IP de origem do TUNEL
  • tunel source <int>:  especifica a origem do tunel como a interface selecionada (recomendado quando usado com portas seriais)
  • tunel destination <IP>: Especifica o IP de destino do TUNEL

Comandos do Modo Configuração de Vlan 

Este modo permite a configuração das redes virtuais .
  • name <nome> .define um nome para a rede virtual
  • no name .retira o nome da rede virtual

Teclas de atalho

  • ctrl + shift + 6: interrompe um processo
  • ctrl + c : aborta o comando atual ou sai do modo de configuração
  • tab : completa o comando atual
  • ctrl + r: localiza um comando

Obs: Diferentes memórias do dispositivo

  • NVRAM: memória de acesso aleatório (RAM) não volátil (NV). Onde são guardados os arquivos de configuração (startup-config)
  • FLASH: Memória onde é guardado o SO.
  • RAM: Memória de acesso aleatório onde ficam em ex

Configuração de VLANS

  • Listagem de informações a respeito de VLANS (modo exec privilegiado)
    • show vlan brief: verifica as configurações de vlan do dispositivo.
    • show vlan name <nome>: verifica as configurações de uma vlan específica
  • Configuração de VLANS (modo configuração global)
    • vlan <vlan-id>. abre as configurações da vlan-id selecionada
      • name <vlan-name>: define o nome da vlan
      • ip address  <ip> <mascara>: define um IP para a VLAN
    • no vlan <vlan-id>remove uma vlan especificada
    • delete flash:vlan.dat: remove todas as vlans

Configuração de roteamento RIP v1 e v2: Hostname (config-router)#

  • network <ip de rede>: habilita o roteamento da rede <ip>. Anuncia aos vizinhos o numero de saltos da rede para os vizinhos. Além disso, habilita a placa de rede associada a rede <ip> para anunciar sua tabela de roteamento pela interface.
  • passive interface <tipo numero de interface> : Desabilita o anuncio através da interface pois a rede dessa interface não necessita ser roteada (tornando passiva em relação aos anuncios).
  • autosumary: habilita a sumarização de redes de destino que possuem a mesma interface (agrupa redes em super-redes)
  • no autosumary: desabilita a sumarização de redes de destino que possuem a mesma interface (não agrupa redes em super-redes)
  • default-information originate: define a divulgação de uma rota padrão. 
  • version <numero>modifica a versão do algoritmo rip. Versão 1 : Classfull (roteamento por classes ABCD). Versão 2: classlesss (IP/CIRD

Configuração de roteamento EIGRP: Hostname (config-router)#

  • router eigrp <autonomous-system>:  define que que o roteador será parte do sistema autônomo indicado
  • eigrp router-id :  configura o ID do roteador para EIGRP
  • network <ip de rede>: habilita o roteamento da rede <ip>. Anuncia aos vizinhos o numero de saltos da rede para os vizinhos. Além disso, habilita a placa de rede associada a rede <ip> para anunciar sua tabela de roteamento pela interface.
  • show ip eigrp neighbors: para exibir a tabela de vizinhos e verificar se o EIGRP estabeleceu uma adjacência com seus vizinhos
  • metric weights tos <k1 =largura de banda>  <k2 = carga > <k3 = atraso em ms> <k4 = conf >  <k5 = confiabilidade> : para exibir a tabela de vizinhos e verificar se o EIGRP estabeleceu uma adjacência com seus vizinhos
  • traffic-share balanced define  como o tráfego é distribuído entre rotas quando há várias rotas para a mesma rede destino que têm custos diferentes
  • maximum-paths <value> define um número de caminhos que devem ser mantidos para o balanceamento de carga. 
  • redistribute static propagar uma rota padrão estática no domínio de roteamento EIGRP 
  • show ip eigrp topology all-links visualiza a tabela de topologia EIGRP completa do roteador
  • Configurações específicas de interface
    • no auto-summary: desativar a sumarização automática  
    • ip bandwidth-percent eigrp <as-number> <percent>: configura o eigrp para usar no máximo de lagura de banda para a percentagem indicada
    • ip summary-address eigrp <as-number> <network-address> <subnet-mask>: estabelece a sumarização manual do EIGRP em uma interface EIGRP específica.
    • ip hello-interval eigrp <as-number> <tempo>: configura um tempo de hello personalizado.
    • ip dead-interval eigrp <as-number> <tempo>: configura um tempo de dead personalizado, por padrão o tempo de dead é 3x o tempo de hello.
    • ip authentication mode eigrp <as-number> md5habilita a autenticação md5 na interface.
    • ip authentication key-chain eigrp <as-number> <nome da chave>especifica a chave a ser usada na autenticação.
    • ipv6 summary-address eigrp <as-number> <preffix>/<preffix_index>: estabelece a sumarização manual do EIGRP em uma interface EIGRP específica.

ss 

a

Configuração de roteamento RIP ipv6: 

O RIP da versão 6 do IP é configurada de forma diferente da sua versão pro IPv4. Neste caso, deve-se habilitar o rip para cada interface. Lembrando que é necessário habilitar o unicast routing do ipv6 através do comando ipv6 unicast routing e em seguida deve-se habilitar o ipv6 rip através do comando
  • ipv6 router rip <NOME>
Para finalizar, entra-se na interface e habilita o RIP
.
  • interface fa0/1
    ipv6 rip <nome> enable
    no shutdown

Configuração de roteamento OSPF: Hostname (config-router)#

Para acessar esse modo de configuração é necessário chamar o comando router ospf <id_processo> 
  • network <ip de rede> <mascara coringa> area <numero>: habilita a divulgação da rede através da área <NUMERO> do OSPF. Obs: a máscara coringa é subtraindo 255 da mascara de rede 
  • passive interface <tipo numero de interface> : Desabilita o anuncio através da interface pois a rede dessa interface não necessita ser roteada (tornando passiva em relação aos anuncios).
  • auto-cost reference-bandwidth 1000define a referência para cálculo do custo do OSPF
  • Configuração de autenticação para a área <id>
    • area <area-id> authentication message-digest:  define que a área selecionada irá enviar pacotes OSPF criptografados.
    • area <area-id> range <network-address>:  configura o roteador para preparar uma rota sumarizada da rede indicada.
    • summary-address address mask:  instrui o ASBR a criar rotas sumarizadas de uma rede externa indicada.
    • ip ospf priority <prioridade>
    • ip ospf hello-interval <tempo>
    • ip ospf dead-interval <tempo>
  • default-information originate: propaga a rota padrão para outros dispositivos.
  • passive-interface default : desabilita a propagação do ospf por todas as interfaces.
  • passive-interface <interface> : desabilita a propagação do ospf pela interface selecionada.
  • no passive-interface <interface> : habilita a propagação do ospf pela interface selecionada.

ACLs#

Uma ACL é uma série de comandos de IOS que controlam se um roteador encaminha ou elimina pacotes com base nas informações encontradas no cabeçalho do pacote.
  • ACL NUMERADA
    • abaixo de 100 - ACL Padrão:
      • access-list <num> <permit | deny > <num> <ip> <mascara coringa> : permite ou bloqueia o tráfego com ip de destino e máscara de rede coringa.
      • access-list 1 deny 192.168.0.0 0.0.0.255
      • access-list 1 deny 192.168.0.10 host
    • acima de 100 - ACL Extendida:
      • access-list <num> <permit | deny > <num> <ip> <mascara coringa> <eq | > <porta> : permite ou bloqueia o tráfego com ip de destino e máscara de rede coringa.
      • access-list <num> <permit | deny > <num> <ip> <mascara coringa> <eq | > <porta> destination  <ip> <mascara coringa> <eq | > <porta> : permite ou bloqueia o tráfego com ip de destino e máscara de rede coringa para um destino específico.
  • ACL NOMEADA
    • padrao: ip access-list <nome> standard NOME: entra no modo de configuração da ACL nomeada. usa-se permit / deny e remark para inserir as regras.
    • extendida: ip access-list <nome> extended NOME: entra no modo de configuração da ACL nomeada. usa-se permit / deny e remark para inserir as regras.
  • interface Se0/0/0
    ip access-group <num > <in | out > : 
    habilita o uso da ACL numa porta específica.
  • auto-cost reference-bandwidth 1000define a referência para cálculo do custo do OSPF

DHCP

Nesta seção serao descritos os passos necessários para configurar um servidor dhcp.

  1. Primeiro remove os ips reservados a servidores
    1. ip dhcp excluded access <ip inicial> <ip final>
      1. ip dhcp excluded-address 192.168.45.1 192.168.45.20
      2. ip dhcp excluded-address 192.168.47.1 192.168.47.20
  2. Cria um pool
    1. ip dhcp pool <name>
      1. ip dhcp pool VLAN45
  3. Configura o POOL
    1. network <ip de rede> <mascara>
    2. default-router <ip do gateway>
    3. doman-name <nome do dominio da rede>

NAT

Nesta seção serao descritos os passos necessários para configurar um NAT e PAT.

  • Definição do NAT
    • ip nat inside source static <ip interno> <ip externo>: define um nat estático
    • ip nat pool PAT 198.133.219.128 198.133.219.129 netmask 255.255.255.254 : define um PAT dinâmico
  • Definição de Perímetro (Direção)
    • Definir se a interface é nat inside ou nat outside.

Tipo Conexão Comando
Direção Endereço Inside Local Endereço Inside Global Habilitar o Pat
Estático 1-1 ip nat inside source static <IP> <IP Externo> ou <Interface>
Dinâmico M-1 ip nat inside source list <ACL>¹ <IP Externo> ou <Interface> overload
M-M ip nat inside source list <ACL> pool <NAT_POOL>²

¹ access-list <NUM> permit 10.0.0.0 0.255.255.255 
² ip nat pool <NAT_POOL> AcessoInet 200.0.0.2 200.0.0.6 netmask 255.255.255.248

Hyper-V

postado em 9 de mar. de 2014 14:58 por Prof. Rodrigo Costa   [ 22 de mar. de 2014 04:17 atualizado‎(s)‎ ]

Atualmente, o poder computacional dos computadores pessoais é bastante elevado. Por causa disto, os desktops e notebooks são suficientemente poderosas para possibilitar a execução de vários sistemas completos (programas básicos e programas aplicativos) sob um único hardware físico, ou seja, podem processar não somente o seu sistema operacional, mas também hospedar outras máquinas virtuais com diferentes Sistemas Operacionais.

Existem diversos fabricantes de sistemas de virtualização para computadores servidores e desktop. Para desktop, as soluções mais conhecidas são o Virtualbox da Oracle e o Vmware Workstation. Em termos de servidores, segundo o quadrante mágico da virtualização, as soluções da Microsoft (Hyper-V) e da VMWare (ExSI) são as soluções mais utilizadas.

Inicialmente, o Hyper-v era uma função (Role) do Windows Server 2008 que fornece uma interface para gerenciamento de máquinas virtuais. Dependendo do tipo de licença do Windows Server, o usuário poderia hospedar de 2 até um número ilimitado de máquinas Windows Server com uma só licença. 

A partir do Windows 8, o Hyper-V foi incorporado como um recurso do sistema para desktop nas versões Professional e Enterprise. Contudo, antes de poder ativar este recurso de virtualização nativo do Windows 8, o usuário deve verificar se o seu sistema atende os seguintes requisitos.
  • Versão 64 bits do Windows 8 Professional ou Enterprise
  • 4 GB de memória RAM
  • Processador com suporte de virtualização de 2º Nível 
  • Recurso de virtualização ativado.
Um diferencial do Hyper-V é que ele roda em background, assim, o usuário pode inicializar uma MV e deixá-la rodando no plano de fundo. Neste tutorial, é apresentado um passo a passo para ativar o recurso e um passo a passo com recomendações para a criação de máquinas virtuais.


1. Ativando o Hyper-V no Windows 8.

Para ativar o recurso, o usuário deve realizar a seguinte sequência de ações:
- Pressionar o botão windows > digitar "Recursos do Windows" > Clicar em configurações > Clicar em Recursos do Windows, conforme mostrado na figura a seguir:
- Marcar para a instalação dos recursos do Hyper-V. > Clicar em OK


A plataforma Hyper-V é o recurso de Virtualização em SI enquanto que as Ferramentas para gerenciamento do Hyper-v permitem apenas a interface com o usuário. Com as configurações corretas na máquina local e em máquinas remotas, é possível administrar o recurso Hyper-V de outras máquinas, sejam elas Windows 8 ou Windows Server 2012.

Depois disto, o Hyper-V está disponível e pode ser acessado através do menu Iniciar. 

 

Ao clicar no Gerenciador do Hyper-V a janela de gerenciamento é mostrada e as principais funcionalidades são apresentadas na figura a seguir:



2. Criando Máquinas Virtuais

Antes de criar as máquinas virtuais, deve-se tomar a precaução de configurar perfis de adaptadores de rede virtuais. Após realizar este procedimento, pode-se criar as máquinas virtuais.

2.1. Configurando o comutador virtual


O Hyper-V relaiza a conexão de rede das máquinas virtuais com três tipos de switchs (comutadores) virtuais. Basicamente, o usuário configura o tipo de comutação a ser realizada e 
o hyper-v conecta a máquina virtual neste Switch. Os três tipos de comutadores virtuais disponíveis no Hyper-v são:



Privado
Este comutador se destina a prover conectividade exclusiva entre máquinas virtuais. 

Interno
Este tipo de comutador permite conectividade das máquinas convidadas com apenas a máquina hospedeira. 

Externo
Este tipo de comutador permite o compartilhamento de uma interface de rede da máquina hospedeira com suas clientes. Este tipo de configuração é o ideal quando é desejável acessar recursos disponíveis na máquina virtual através de estações da rede local.


Para configurar os comutadores virtuais disponíveis em seu hyper-v, com a interface do hyper-v aberta, o usuário deve clicar em Gerenciador do comutador virtual.
  1. Clicar em Gerenciar comutador virtual
  2. Clicar Novo Comutador de rede virtual
  3. Escolher o tipo de comutador de sua preferência
  4. Clicar em Criar comutador virtual 
  5. Para concluir, clique em ok para voltar a tela de gerenciamento do hyper-V.
Para gerenciar um comutador virtual previamente clicado, basta clicar sobre o nome do comutador virtual e os detalhes de configuração são apresentados. A interface é muito simples, permite alterar o tipo, renomear o comutador.

Observações

1. Em redes externas, o usuário deve escolher qual interface de rede será compartilhada entre o hospedeiro e suas máquinas virtuais.
2. Ao desmarcar a opção "Permitir que o sistema operacional de gerenciamento compartilhe este adaptador de rede", o usuário faz com que a interface de rede se torne exclusiva para as máquinas virtuais. Desta forma, o hospedeiro perde o acesso a interface.
3. É possível criar uma rede do tipo NAT utilizando um comutador interno e compartilhando a conexão da internet de uma interface de rede com a interface lógica do computador hospedeiro. Contudo, ao utilizar esta forma, as máquinas virtuais tem acesso a internet mas os computadores da rede não tem acesso as máquinas virtuais.
4. Ao utilizar interfaces de rede sem fio, o comutador virtual não se comporta muito bem para máquinas virtuais linux. Muitas vezes a máquina virtual não consegue obter IPs através de DHCP. Recomenda-se fortemente o uso de endereçamento estático nas máquinas virtuais linux quando utiliza-se comutadores virtuais sem fio.


2.2 Criando Máquinas Virtuais

Com o comutador virtual criado, a criação de máquinas virtuais se torna extremamente simples. Na interface de gerenciamento, o usuário deve realizar as seguintes instruções (imagens mostradas a baixo das instruções)
  1. Na área de ações sobre o hospedeiro, o usuário deve clicar em novo > máquina virtual. Na primeira interface, o usuário deve ler as recomendações básicas e clicar em avançar.
  2. Logo em seguida, o usuário insere o nome da máquina virtual e também pode escolher o local de armazenamento da máquina virtual.
  3. Depois disso, o usuário escolhe a quantidade de memória RAM usada pela MV. Um diferencial positivo do Hyper-V é que ele permite que a MV utilize memória Virtual, assim, caso o hospedeiro fique com pouca memória RAM disponível, a máquina não para de funcionar, apenas funcionará mais lentamente por utilizar a memória virtual
  4. Selecionar o comutador virtual a ser utilizado pela máquina virtual.
  5. Seleciona o local e o tamanho do disco rígido.
  6. Especificar a forma de realização de boot e pressionar concluir
 


Criando MVs no Hyper-V


Depois disso, a máquina está pronta para ser iniciada. Basta clicar com o botão direito e em seguida clicar em inicializar. Para ter acesso ao teclado, mouse e monitor da MV o usuário deve clicar em conectar ou dar dois cliques sobre o nome da máquina.

Um bom exercício é instalar o Windows XP na máquina virtual. Um bom tutorial está disponível em http://galisteobio.blogspot.com.br/2010/09/veja-como-instalar-o-windows-xp.html

OBS: Recomendações para instalação do Windows XP

  1. Crie sempre duas partições, uma para o sistema e outra para os dados do usuário
  2. Na primeira tela da interface gráfica o usuário deve escolher o teclado correto. Por exemplo, a maior parte dos teclados no brasil é ABNT2 e deve-se clicar em detalhes para inserir este layout de teclado.
  3. Após inserir o layout correto, recomenda-se remover todos os layouts que não são utilizados para evitar que por algum comando de teclado ou preferência de aplicação que alterne o layout de teclado.
  4. Na tela que solicita-se a senha de administrador, deve-se inserir uma senha pois o usuario administrador ele só não aparece para login, mas pressinando cltrl + alt + del na tela de boas vindas, abre-se uma janela que permite o login através do nome do usuário.

Instalacao do Windows XP

Instalacao do Ubuntu


OpenXenManager

postado em 17 de set. de 2013 04:57 por Prof. Rodrigo Costa   [ 17 de set. de 2013 05:24 atualizado‎(s)‎ ]

O XenCenter é a ferramenta de gerenciamento do servidor XenServer. Para obtê-lo, deve-se acessar o ip do servidor de virtualização no browser e fazer o download.

Apesar do XenServer ser baseado no CentOS (um Linux), seu gerenciador só possui versões para Windows.

Mas, como toda interação é feita através de protocolos, basta implementar um programa que interaja com o  servidor seguindo as especificações do protocolo. E foi isso que foi feito através do OpenXenManager, disponível em http://sourceforge.net/projects/openxenmanager/ 

Este tutorial tem como objetivo apresentar o guia rápido para configuração do OpenXenManager no Ubuntu 13.10.

$ sudo su
# wget -c http://sourceforge.net/projects/openxenmanager/files/latest/download -O openxenmanager.tar.gz
# tar -zxf openxenmanager.tar.gz
# apt-get install python-gtk2 python-gtk-vnc rrdtool python-rrdtool python-glade2 python-httplib2
# mv openxenmanager/ /opt
# echo #!/bin/bash > openxenmanager
# echo python /opt/openxenmanager/window.py >> openxenmanager
# chmod 777 openxenmanager
# mv openxenmanager /usr/bin
# exit

Após a configuração, basta chamar o comando openxenmanager em qualquer pasta para acessar o servidor.
$ openxenmanager

Ao clicar em + Add Server, deve-se configurar o servidor e ativar a conexão SSL com o servidor, conforme apresentado na Figura:

Voilá.... O acesso ao servidor está disponível e pronto para a utilização.

Observações: 

Em vários sites, encontrei tutoriais, mas nenhum deles funcionou no Ubuntu 13.04. Aconteceram vários tipos de erros:
  •   File "/opt/openxenmanager/window.py", line 46, in <module>
        import gtk.glade
    ImportError: No module named glade
    Faltava instalar o pacote phyton-glade2 (inserido no apt-get de dependências)
  • Unexpected error: (<class 'httplib.ResponseNotReady'>, ResponseNotReady(), <traceback object at 0xade12a2c>)
    Traceback (most recent call last):
      File "/opt/openxenmanager/oxcSERVER.py", line 1814, in event_next
        eventn = self.connection.event.next(self.session_uuid)
      File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__
        return self.__send(self.__name, args)
      File "/usr/lib/python2.7/xmlrpclib.py", line 1578, in __request
    Exception in thread Thread-3:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
        self.run()
      File "/usr/lib/python2.7/threading.py", line 763, in run
        self.__target(*self.__args, **self.__kwargs)
      File "/opt/openxenmanager/oxcSERVER_addserver.py", line 287, in fill_tree_with_vms
        self.wine.finish_progressconnect()
      File "/opt/openxenmanager/window_addserver.py", line 85, in finish_progressconnect
        self.xc_servers[self.selected_host].fill_alerts(self.listalerts)
      File "/opt/openxenmanager/oxcSERVER_addserver.py", line 46, in fill_alerts
        self.session_uuid)['Value']
      File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__
        return self.__send(self.__name, args)
      File "/usr/lib/python2.7/xmlrpclib.py", line 1578, in __request
        verbose=self.__verbose
      File "/usr/lib/python2.7/xmlrpclib.py", line 1264, in request
        return self.single_request(host, handler, request_body, verbose)
      File "/usr/lib/python2.7/xmlrpclib.py", line 1289, in single_request
        self.send_request(h, handler, request_body)
      File "/usr/lib/python2.7/xmlrpclib.py", line 1391, in send_request
        connection.putrequest("POST", handler, skip_accept_encoding=True)
      File "/usr/lib/python2.7/httplib.py", line 871, in putrequest
        raise CannotSendRequest()
    CannotSendRequest

    Este problema é causado pela falta da instalação do pacote phyton-httplib2, inserido também nas dependências do openxenmanager.

Tortoise GIT

postado em 5 de set. de 2013 03:40 por Prof. Rodrigo Costa   [ 5 de set. de 2013 05:26 atualizado‎(s)‎ ]

O GIT é um Sistema de Controle de Versão desenvolvido pelos criadores do Linux para ser utilizado no próprio desenvolvimento do sistema operacional visto a mudança nos termos de licença do BitKeeper.

O GIT tem muitas funcionalidades pois foi inicialmente idealizado para servir de base para a criação de sistemas de controle de versão de alto nível, como o que aconteceu com o COGITO. Contudo, durante o seu desenvolvimento, ele acabou por se tornar um sistema de controle de versão completo, podendo ser utilizado diretamente pelos usuários.

O Git tem recursos fantásticos, mas ele possui uma pior usabilidade visto que ele necessita de de uma configuração mais complicada que o SVN.
No svn basta instalar uma ferramenta cliente e pronto, já pode acessar o repositório, conforme apresentado em post anterior.
 
O Git necessita de pequenas configurações para acessar o repositório e requer um pouco mais de esforço para começar a usar. Existem diversos tutoriais na net ensinando como acessar o repositório, principalmente através da linha de comando. Um exemplo deste é o tutorial preparado pelo Jardel que ficou muito legal. Quem quiser ver o tutorial, clique aqui!!!

A interação básica com repositórios git envolve uma série de comandos, mas na figura a seguir, são ilustrados os comandos mais utilizados pelos usuários deste sistema de controle de versão, similar a figura que usei para descrever a interação básica com o SVN.


De qualquer forma, a versão GUI do MSYSGIT ajuda, mas não tem uma interação tão dinâmica que muitos desenvolvedores preferem utilizar o prompt de comando. Como já estou acostumado com o SVN e a sua versão de Tortoise, pois ela se integra ao Windows Explorer e fornece a capacidade de interação com repositório mais dinâmica.

1. Instalando o TortoiseGIT
A instalação do TortoiseGIT requer a instalação do MSYSGIT, após instalá-lo vc deve baixar e instalar o TortoiseGIT.

2. Acessando um repositório existente

   


   


   


   


   


TortoiseSVN

postado em 3 de nov. de 2012 15:54 por Prof. Rodrigo Costa   [ 5 de set. de 2013 04:52 atualizado‎(s)‎ ]


O subversion é um Sistema de Controle Versão (SCV) centralizado que existe desde outubro de 2000, conhecido por ser gratuito e de código aberto. Um SCV é gerencia arquivos e diretórios, e as modificações feitas neles ao longo do tempo, sendo bastante útil para acompanhar as alterações de arquivos durante o desenvolvimento de projetos. 

Uma prova de sua importância foi um relatório feito pela Forrester Research em 2007 que constatou o SVN como líder no segmento de controle de versão. Até hoje, este sistema é utilizado por grandes empresas no Brasil e no mundo, você pode perceber que nas seguintes vagas [1][2] e [3] é requisitado a experiência no uso deste SCV. 
Se você gostou deste tutorial ou ele lhe foi útil, clique em curtir.

Um SCV centralizado funciona da seguinte forma, existe um repositório (onde são controladas todas as versões dos arquivos). Para um usuário começar a interagir com um repositório,  faz-se necessário obter uma cópia local do repositório através de uma operação chamada de checkout. Esta operação foi marcada como (1) na figura abaixo.  

Todo desenvolvedor tem sua própria cópia de trabalho local, algumas vezes conhecido como sandbox, no seu PC local. Com a cópia local, os usuários podem começar a trabalhar e fazer alterações nos arquivos. Nesta fase, marcada como (2) na figura acima, o usuário pode inserir arquivos na cópia local, alterar arquivos, remover arquivos da cópia local. Alterar ou remover os arquivos não é uma solução final, pois quando você se sincronizar com o repositório, ele irá considerar que você acidentalmente removeu o arquivo, pois seu repositório local não foi modificado. Os comandos svn add, svn move e svn delete, são responsáveis, por modificar seu repositório local,  tornando possível adicionar, remover ou mover arquivos no repositório local, respectivamente.

Antes de poder enviar suas alterações no sistema, o usuário deve atualizar sua cópia local, unificando as alterações feitas por outros usuários com o seu repositório local (4). Durante o passo 4 podem acontecer problemas de sincronismo, ou seja, outro usuário pode ter alterado o mesmo arquivo que o usuário alterou em seu repositório local, assim é necessário resolver esses problemas através de operações de da mesclagem ou resolução de conflito, marcado como (5) . Após resolver os problemas, pode-se submeter suas alterações através de operação de commit

Pode-se realizar a interação com o servidor utilizando comandos em prompt de comando, mas uma interface gráfica pode simplificar bastante o processo de interação com o repositório. Dentre as diversas disponíveis na net, particularmente, gosto do TortoiseSVN, uma ferramenta que é fácil de instalar e também de utilizar, pois ela se integra o WindowsExplorer.

1. Instalando o SVN

O TortoiseSVN é bastante simples de instalar. Inicialmente você precisa escolher qual versão instalar:
Após fazer o download, o usuário deve clicar duas vezes no arquivo de instalação e seguir as instruções. O instalador cuida de tudo pelo usuário e após a reinicialização do sistema, o TortoiseSVN estará integrado ao Windows Explorer. Ao clicar com o botão direito em qualquer pasta ou em qualquer espaço vazio da área de trabalho, você poderá ver as operações:
  • SVN Checkout: responsável por fazer o download de um repositório e criar a cópia local.
  • Tortoise SVN: criar novos repositórios na máquina local e configurar opções do Tortoise.

2. Manipulação básica do Tortoise

Para baixar uma cópia local de um repositório, clica-se com o botão direito em qualquer espaço vazio da área de trabalho e em seguida clica-se em SVN Checkout, conforme mostrado na figura abaixo à esquerda. Na interface, digita-se o url do servidor, por exemplo svn://servername/myproject
 
Após inserir as credenciais do usuário, sua cópia local está criada e o usuário pode realizar os seguintes comandos com apenas um clique do mouse:
  • Update: atualizar sua cópia local para a versão mais recente do repositório;
  • Commit: enviar suas alterações para o repositório;
  • Add: inserir arquivos no seu repositório;
  • Diff: verificar as diferenças entre um arquivo do repositório local e sua versão mais recente no repositório;
  • Delete: remover arquivos do repositório;
  • Reverter: cancela todas as alterações feitas, restaurando as alterações dos arquivos para a versão mais recente do repositório;
  • Revision Graph: mostra em um gráfico o histórico das alterações;
  • Show Log: mostra uma tabela com o histórico das alterações, bem como os comentários feitos a cada interação.

3. Enviando suas alterações

Ao fim de um dia de trabalho, todo desenvolvedor deve fazer o seu commit fazendo com que suas alterações sejam disponibilizada aos demais desenvolvedores, ao clicar com o botão direito na pasta e em seguida clicar em svn commit (mostrado à esquerda). 

Após clicar em commit, surge uma janela em que o usuário pode escolher quais arquivos vai realmente comitar e é importante deixar uma mensagem aos demais desenvolvedores, indicando o conteúdo de suas alterações.



Após inserir os comentários, o usuário clica em OK e envia as alterações, ao final do processo, é mostrado o status do commit.

4. Configurações adicionais

Para versionar apenas arquivos importantes ao projeto, deve-se evitar enviar arquivos desnecessários ao repositório. Por exemplo, não há necessidade de versionar arquivos usados durante o processo de montagem e compilação (.o, .a, .dll). Ou então, arquivos com a extensão .bak também não são necessários pois o SVN já versiona os arquivos. Assim, ao invés de tomar esta preocupação manualmente, pode-se configurar o TortoiseSVN para ignorar os arquivos.

Para ignorar os arquivos clique em qualquer lugar da área de trabalho > Tortoise SVN > Settings, clica-se na aba Gerenal e digita a extensão a ser ignorada em Global Ignore Pattern. Neste campo, preenche-se as extensões ou diretórios digitando as extensões separadas por espaços. No meu computador,  esta configuração está assim: 
*.bak *.bin *.layout *.depend *.o *.a *.so *.dll 


Xen Server

postado em 26 de mai. de 2012 16:44 por Prof. Rodrigo Costa   [ 1 de mai. de 2013 10:38 atualizado‎(s)‎ ]

 Olá, acho que nem todo mundo sabe, mas agora ando me aventurando com virtualização de servidores.

A virtualização de servidores é uma tecnologia que permite, através do compartilhamento de hardware, que múltiplos sistemas operacionais possam ser executadas em um único servidor físico.

Algumas vantagens da virtualização são:
  • Reduz os custos através da consolidação de servidores e redução de energia, refrigeração e espaço de datacenter;
  • Aumenta a flexibilidade, permitindo o provisionamento de novos servidores e serviços de TI dentro de minutos;
  • Garante que os requisitos das aplicações e níveis de desempenho são sempre cumpridas;
  • Minimiza o tempo de inatividade, reduzindo o impacto de falhas e de protecção contra catástrofes.
Após instalar o XenServer na máquina, deve-se utilizar o XenCenter para controlar o servidor remotamente. A seguir mostra-se uma imagem do sistema.


O bacana do xen é que pode-se fazer um agrupamento de servidores (que possuem o XenServer), oferencendo uma plataforma para gerenciamento de VMs, podendo ser startadas em diferentes servidores ou até mesmo migradas entre eles durante a execução do sistema.

Neste post irei descrever o passo a passo de algumas ações que podem ser feitas no xen 5.6 (versão que uso)

Sugiro a quem for se aprofundar no xen, utilizar referencias como esta.

1. Atualizando pacotes ou instalando pacotes adicionais

O XenServer usa o CentOS como distribuição base e com ele podemos criar VMs tanto do Linux quanto do Windows, com versões livres e comerciais.

Assim, você poderia pensar, como ele é baseado no CentOS que é baseado num RedHat, bastaria chamar o comando
yum install pacote 
mas nem sempre os pacotes estão atualizados. 

Assim, para conseguir instalar novos pacotes deve-se inserir um novo repositório
  1. Baixando os arquivos de configuração do novo repositório
    wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.i386.rpm
  2. Configurar o novo repositório
    rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txtrpm -i 
    rpmforge-release-0.5.2-2.el5.rf.i386.rpm
  3. Agora na hora de baixar um novo pacote, desabilitando o repositório padrão (citrix) e habilitando o novo repositório
    yum --disablerepo= citrix --enablerepo=rpmforge --enablerepo=base install <pacote>

Caso você queira deixar permanente a desabilitação ou habilitação um repositório você deverá editar o arquivo /etc/yum.repos.d/repo e colocar enabled = 0 para desabilitar e enabled = 1 para habilitar

2. Montando um hd externo NTFS

Para montar um hd externo em ntfs basta você instalar o pacote fuse-ntfs
yum --disablerepo= citrix --enablerepo=rpmforge --enablerepo=base install fuse-ntfs-3g 

Depois disso, basta fazer o comando de montagem padrão
mount /dev/sdX1 /mnt  
obs: o servidor monta a pasta no modo somente leitura.

3. Criando uma biblioteca de ISOs local

Para montar um hd externo em ntfs basta você instalar o pacote fuse-ntfs
xe sr-create name-label=Servidor type=iso \
device-config:location=/mnt \
device-config:legacy_mode=true content-type=iso 

Depois disso, basta dar 
xe vdi-list sr-name-label=<Name of SR> params=name-label,name-description,physical-utilisation,virtual-size 


Protegendo seus arquivos usando o Truecrypt

postado em 14 de mar. de 2012 18:41 por Prof. Rodrigo Costa   [ 19 de mar. de 2014 12:58 atualizado‎(s)‎ ]


 Sempre é bom manter seguro os arquivos pessoais, evitando que os mesmos caiam em mãos erradas. Existem diversas formas de proteger a informação e uma delas é usando a encriptação de arquivos.

A criptografia de informação consiste em modificar os dados que a representam a fim de proteger o conteúdo do mesmo. Assim, através de uma série de transformações nos evitar que caso algum intruso obtenha acesso aos dados, o mesmo obtenha a informação.

Por exemplo, caso você queira evitar que uma conversa sua seja interceptada por alguem, basta codificá-la usando algum algoritmo de criptografia. O destinatário deverá conhecer a forma de criptografia e com ela, conseguirá acesso à mensagem original.


Truecrypt

O truecrypt é uma solução de código aberto (open source) e gratuita para encriptar um único arquivo ou, até mesmo, uma pendrive ou disco rígido por completo.

A grande vantagem dele é que ele se integra ao Windows Explorer com uma grande facilidade e pode ser utilizado tranquilamente por usuários com pouca experiência.

Existe uma outra grande vantagem, o backup, basta agendar políticas para fazer backup do container e assim, simplificar até mesmo a cópia dos dados.

Vejam a seguir como o sistema se comporta:
 
No Windows explorer, os arquivos encriptados e os discos rígidos aparecem como unidades. Mas na verdade, parte destas unidades são na verdade um arquivo que está sendo manipulado através do Truecrypt
Na verdade, as unidades Y e Z são configuradas e mantidas pelo Truecrypt.

Neste tutorial, mostramos os links de instalação e algumas configurações mais simples para iniciar o uso da solução. Ela é bem complexa e cabe aos interessados aprofundarem seus conhecimentos.

Passo 1: Obtendo o arquivo e instalando

No caso, não lembro de configurações adicionais, basta obter o link do donwload e durante a instalação, ir avançando até chegar ao seu fim.
Os links para download são estão dsiponíves para download no site http://www.truecrypt.org/downloads

Passo 2: Criando o seu próprio container.

Para simplificar meu trabalho, peguei as figuras no site http://www.guidingtech.com/1258/how-to-encrypt-computer-data-using-truecrypt/, mas vou explicando aqui no meu site.
 Na tela principal clique em criar volume (Create Volume).



http://www.guidingtech.com/assets/postimages/2010/02/TrueCrypt18.png
 Existem várias formas de criar um volume. No caso existem três opções:
a) criar um arquivo que será representado por um drive virtual
b) Encriptar uma partição inteira que não é usada por um sistema e
c) Encriptar uma partição inteira usada pelo próprio
Na terceira, até o bootloader é modificado, por isso recomendo o uso da primeira opção.

  No caso, eu uso a idéia de criar um volume padrão (que após a solicitação de uma senha, libera o acesso aos dados.
 Na próxima tela, indica-se qual arquivo conterá os dados da unidade virtual.

Na próxima tela, indica-se o algoritmo de criptografia de dados e ao apertar o botão next, será solicitado o tamanho do arquivo.

Por fim, na última tela, digita-se a senha de proteção do arquivo.

O ideal é criar uma senha forte, contendo números, letras minúsculas e maúsculas e caracteres especiais como @ ^= $ ² +, etc.

Passo 3: Montando um arquivo encriptado como unidade do Windows


No caso, primeiramente é necessário montar na primeira vez manualmente o arquivo encriptado. para isto, faz-se os seguintes comandos:

Inicialmente, você na tela principal irá indicar uma letra para associar ao arquivo criptografado.

Depois de escolher, basta clicar em montar.

Depois disto, é solicitado uma senha

E pronto, agora você tem uma unidade virtual que na verdade armazena os arquivos de forma encriptada.

Caso você queira desmontar a partição, dentro do truecrypt, basta clicar na letra dela em depois em desmontar.

Passo 4: Fazendo o truecrypt iniciar junto ao sistema e fazer com que o mesmo solicite a senha e deixe disponível o acesso ao container encriptado.

Agora, para você montar automaticamente, primeiramente, temos que definir os arquivos atualmente montados (associados a uma unidade) como volumes favoritos.

Clica-se em volume e depois Save Currently Mounted Volumes as Favorite

Depois de salvá-lo como volume favorito, vamos configurar as preferências do Truecrypt.
  • Vai em Settings > Preferences.
  • Na Janela que é aberta, clica-se em Start Truecrypt Background Task e Mount favorite volumes.
  • Após isto, aperta-se ok.

Quando você reiniciar o sistema, assim que o sistema for reinicializado, ele irá solicitar a senha e montará para você, caso você não deseje montar no momento, basta clicar em cancelar.

Abraço a todos!!

Importando cursos do Moodle

postado em 14 de mar. de 2012 03:52 por Prof. Rodrigo Costa   [ 23 de abr. de 2012 05:26 atualizado‎(s)‎ ]


O moodle é uma ferramenta fantástica disponível para ensino a distância. No meu caso, gosto de usar o moodle como apoio a disciplina presencial, principalmente para aplicar listas de exercícios e questionários.
 
Ao terminar um semestre e começar um novo, pensa-se "será que é complicado importar os dados de um curso antigo e criar um novo?"
A resposta é não! Com poucos cliques conseguimos importar um curso inteiro e deixá-lo limpo para uma nova turma.

 Passo 1: Solicitar a importação de um curso

clicando no botão importar da guia administração

 Passo 2: Escolher o curso que você deseja importar

No caso, é bem simples, aparece uma guia para você escolher o curso

depois disso é só apertar o botão usar esse curso



Passo 3: Escolhe o que você vai querer importar do curso antigo

 Passo 4: Continuar avançando até concluir





1-8 of 8